0
篇帖子
背景:A、B、C三台服务器已做过互信。
问题:node服务启动需要编写一键启停脚本,但是服务器A一直启动失败。
原因:ssh远程执行脚本时,无法获取服务器的全局环境变量,需要在脚本里加上source /etc/profile命令,让脚本先加载环境变量后,在执行启停命令。
解决方案:
①执行多条命令时:(每个命令之间用;分割,所有命令用双引号包起来,均使用英文符号)
ssh ip地址 "source /etc/profile;/home/deploy.sh start"
②执行单条命令时:
ssh ip地址 source /etc/profile
评论交流
写下你的想法,与大家一起交流